10.1 System Requirements

OpenClinica has a flexible architecture that can run on numerous infrastructure combinations. General system recommendations are as follows:

Single server environment hardware recommendation (OpenClinica and PostgreSQL Databases reside on the same server):

Minimum:
Linux (RedHat 6 or CentOS 6.x)
CPU: Quad core 2GHz+ CPU
RAM: 4GB
Disk space: 100GB

Recommended:
Linux (RedHat 6 or CentOS 6.x)
CPU: Quad core 2GHz+ CPU
RAM: 16GB
Disk space: 500GB

Multiple-server environment hardware recommendation (OpenClinica and PostgreSQL Databases reside on separate servers)

Minimum:
Linux (RedHat 6 or CentOS 6.x)
CPU: Quad core 2GHz+ CPU
RAM: 2GB (OpenClinica), 2GB (PostgreSQL/Database)
Disk space: 100GB

Recommended:
Linux (RedHat 6 or CentOS 6.x)
CPU: Quad core 2GHz+ CPU
RAM: 8GB (OpenClinica), 4GB (PostgreSQL/Database)
Disk space: 500GB

Recent production versions of OpenClinica have been verified to run on the following components:

Version Server OS Database Application Server Language Memory Disk Client Browser
3.10 - 3.13

RHEL/CentOS 
6.5  or above 
64-bit
(recommended)

Windows 2012, 
R2 or above
64-bit

Windows 2008, 
64-bit

Postgres 9.5

Postgres 8.4

Apache Tomcat 7.0.x JDK 7

2GB

20GB

IE 11+

Firefox 30.0+

3.6 - 3.9

RHEL/CentOS 
6.5  or above 
64-bit
(recommended)

Ubuntu 12.04 
LTS
64-bit

Windows 2012, 
R2 or above
64-bit

Windows 2008, 
64-bit

Postgres 8.4

Apache Tomcat 7.0.x JDK 7

2 GB

20GB

IE 11+

Firefox 30.0+

3.4, 3.5

RHEL/CentOS 
6.5  or above 
64-bit
(recommended)

Ubuntu 12.04 
LTS
64-bit

Windows 2012, 
R2 or above
64-bit

Windows 2008, 
64-bit

Windows 2003 R2 or above
32-bit
(not recommended)

Postgres 8.4

Apache Tomcat 7.0.x JDK 7

2 GB

2 GB

IE 11+

Firefox 30.0

3.3

RHEL/CentOS 
6.5  or above 
64-bit
(recommended)

Windows 2003 R2 or above
32-bit

Ubuntu 12.04 
LTS
64-bit

Postgres 8.4

Apache Tomcat 7.0.x JDK 7

2 GB

2 GB

IE 11+

Firefox 25.01

3.2

Windows 2003 R2

CentOS 6.5 (~Red Hat Enterprise Linux 6.4)

Ubuntu 12.04 LTS

Postgres 8.4

Apache Jakarta Tomcat 6.0.32 or 7.0.42 (recommended) JDK 6 or JDK 7 (recommended)

256 MB minimum

2 GB recommended

500 MB minimum

2 GB recommended

IE 11

Firefox 25

3.1

Windows 2003

Red Hat Enterprise Linux 4.0

CentOS

Ubuntu

Postgres 8.4 (recommended)

Oracle 10g

Apache Jakarta Tomcat 6.0.32 JDK 6

256 MB minimum

2 GB recommended

500 MB minimum

2 GB recommended

IE 7 or 8

Firefox 3.0+


Approved for publication by Warren Vandeventer (wvandeventer). Signed on 2017-04-06 10:10AM

Not valid unless obtained from the OpenClinica document management system on the day of use.